Blog d'aide de Blog4ever

Blog d'aide de Blog4ever

Points d'interrogation

641 appréciations
Hors-ligne
Coucou tout le monde !

A propos des points d'interrogation qui s'affichent dans les posts :

Serait-il possible de supprimer ce problème définitivement pour nous éviter de modifier le post quand on oublie (ce qui est mon cas) de faire les manipulations nécessaires pour éviter ce petit souci ?

Merci pour votre compréhension et pardon d'être encore

Belle journée à tous


1872 appréciations
Hors-ligne
Bonjour,

@Maelranaidh@

Je supprime souvent les points d'interrogations dans les messages des blogueurs sur le forum. 

Ils semblent être dus à de multiples balises "center" accolées en BBCode quand des images ou des smileys ont été cliqués "Aligner au centre" en même temps que du texte.

Bon week-end...



641 appréciations
Hors-ligne

Merci beaucoup Daniel pour ton intervention auprès de Maelranaidh.




366 appréciations
Hors-ligne
Bonjour,

Le problème est que, pour corriger un bug, il faut réussir à le reproduire. Et pour l'instant, malgré tous les tests que j'ai fait avec tout un tas de différentes manipulations, je n'ai toujours pas réussi à obtenir ces points d'interrogation.

Donc je suis un peu coincée.

Serait-il possible, de votre côté, de me décrire la liste des manipulations qui les engendre ?

Merci.
Maelyne/Maelranaidh - Developpeuse & Graphiste Blog4ever

641 appréciations
Hors-ligne
Maelranaidh,

Les points d'interrogation s'affichent quand il y a des modifications du texte ou des images ou des émoticônes avant la fonction : "envoyer"

Merci pour ton aide...Bonne journée.

1872 appréciations
Hors-ligne
  @Vonny@

Ce sont de multiples balises de centrage qui apparaissent en BBCode.

Pourrais-tu poster un ou plusieurs message(s) après celui-ci en procédant de la même façon que lorsque le problème se produit.
 
Comme Maelranaidh, je ne parviens pas à reproduire ce bug et comme j'avais corrigé les balises dans les messages concernés, je n'ai pas d'exemple resté en place.

Merci d'avance.

 


641 appréciations
Hors-ligne



?

Belle journée

1872 appréciations
Hors-ligne
@Maelranaidh@

Dans le cas du message ci-dessus, les balises de centrage ne sont pas multiples mais un point d'interrogation s'affiche du fait que l'image (déjà centrée automatiquement) est incluse dans le centrage manuel "Aligner au centre".

Quand il y a de multiples balises "center" d'ouverture et de fermeture accolées en BBCode, cela occasionne l'apparition de plusieurs points d’interrogation. Il semble que, dans ce cas, ce soit dû à plusieurs clics sur des zones incluant à la fois du texte et des images.



641 appréciations
Hors-ligne

J'ai tout modifié (l'émoticône, l'image et le texte)

Avant d'envoyer les messages...

?

366 appréciations
Hors-ligne
Non, de ce que je vois dans la source générée, ça vient du fait qu'il y a parfois un caractère invisible qui se trouve inséré dans le texte quand on utilise la fonction d'alignement au centre. Ce caractère invisible n'est à priori pas pris en charge par l'encodage utilisé pour la base de données donc il se transforme en ? à la sauvegarde.

Ca n'a pas l'air de se produire avec la fonction d'alignement à gauche. Je décortique le javascript qui gère ça mais pour l'instant, je ne trouve rien d'évident qui puisse en être la cause.

Je vais continuer de chercher.

Bonne journée.
Maelyne/Maelranaidh - Developpeuse & Graphiste Blog4ever

641 appréciations
Hors-ligne


et



221 appréciations
Hors-ligne


Tu as sûrement intégré cela dans tes recherches, mais juste au cas où, je signale que c'est un problème récent.

Je ne saurais dire quand je l'ai expérimenté la première fois, mais ça ne doit pas pas faire plus de deux mois.

Il vient peut-être d'une modification récente dans la plateforme.


260 appréciations
Hors-ligne
Bonjour à tous,

Au cas où cela ferait avancer le schmilblick, je signale que j'avais eu ce problème d'un point d'interrogation inséré en tout début d'une reprise d'un texte en citation.

Je vais essayer de retenter la manip (ci-dessous) mais j'ignore si ça va être probant...

?Je ne saurais dire quand je l'ai expérimenté la première fois, mais ça ne doit pas pas faire plus de deux mois.

Je confirme : pas plus de 2 mois que le problème existe.

260 appréciations
Hors-ligne
Bingo ! Ca  a marché : le ? que l'on voit en début de citation a été inséré "à l'insu de mon plein gré" 

1872 appréciations
Hors-ligne
Merci @Réseau BP@ pour ton test. 


@Maelranaidh@

Effectivement, j'ai constaté (sur mon forum privé) que cela se produit aussi avec la balise de citation "quote".

J'avais aussi remarqué que cela se produit depuis une modification concernant le forum, peut-être depuis qu'il n'accepte plus l'HTML mais je n'en suis pas certain.


Vous ne disposez pas des permissions nécessaires pour répondre à un sujet de la catégorie Petits soucis.

Inscrivez-vous au blog

Soyez prévenu par email des prochaines mises à jour

Rejoignez les 5879 autres membres